QuickBasic QB45 und die COM-Schnittstelle

Benutzeravatar
Dianu
Site Admin
Beiträge: 3541
Registriert: Sonntag 5. Februar 2006, 22:35
Wohnort: Westerwald
Kontaktdaten:

QuickBasic QB45 und die COM-Schnittstelle

Beitragvon Dianu » Dienstag 3. Mai 2005, 00:40

Hi,
ziemlich tief musste ich da im Archiv buddeln,
um ein Programmbeispiel von mir wieder zu finden.
Im (Industrie-) PC befand sich eine 8-fach RS232 Schnittstellenkarte,
(Moxxa PCL744), der IPC lief mit MSDOS und einem QB45-Programm.

Anbei ein Stueckchen Code:

l i n k
Liebe Gruesse
Dianu

edgar
Stamm-Mitglied
Beiträge: 5941
Registriert: Samstag 19. Februar 2005, 11:33

Beitragvon edgar » Dienstag 3. Mai 2005, 08:44

Hallo Rudo,

habe den Eindruck,dass wir etwa zur gleichen Zeit mit gleichen Spielzeugen (QB45) beschaeftigt waren. Hast Du die Software damals selbst geschrieben? sieht ja ganz gut aus!.....man wundert sich immer ueber das,was man mal 'gemacht' hat (was Software anbetrifft...und nicht nur ueber das ).
Mit 4800 Bd warst Du auf der sicheren Seite!...

Ed

Benutzeravatar
Dianu
Site Admin
Beiträge: 3541
Registriert: Sonntag 5. Februar 2006, 22:35
Wohnort: Westerwald
Kontaktdaten:

Beitragvon Dianu » Dienstag 3. Mai 2005, 09:54

Hallo Ed,
na klar hab ich die SW selbst gemacht.
Ich muss allerdings auch sagen, dass ich schon auf der Schule Basic hatte (im Rahmen 'numerischer Mathematik' war 50% der Vorlesung Basic)
1979 habe ich dann privat schon meinen ersten 'PC' gehabt, einen PET2000 - mit Basic im EPROM natuerlich ;)
Liebe Gruesse

Dianu

edgar
Stamm-Mitglied
Beiträge: 5941
Registriert: Samstag 19. Februar 2005, 11:33

Beitragvon edgar » Dienstag 3. Mai 2005, 21:09

Rudo,

damals hatte ich die ZX80 / 81 /Spectrum und den Nanocomputer (assembler Z80) von SGS Thompson... alle Speicher in der Groessenordnung von 8k bis zu gigantischen 64k (fast unvorstellbare Groesse)

Alles spaetere unter Dos....(fast) problemlos....bis es mit Windows losging.
Da habe ich den Fehler? gemacht nicht schnell genug mitzumachen und einzurasten...die 'clickerei' habe ich zu lange absichtlich ignoriert.(fand ich echt zu bloede)
Heute weiss ich,dass man mit jedem Shit mitspielen muss.

Frueher habe ich viel Hardware gebaut.....heute nur noch aus Spass....mit
Start-Up von grossen Industrieanlagen lebe ich weit besser ,bereise die ganze Welt und habe weit mehr Zeit fuer mich,die Familie(natuerlich auch mitten in der Woche)...und fuer so manches Forum.
Wie sieht das bei Dir aus?
Ciao
Edgar

Benutzeravatar
Dianu
Site Admin
Beiträge: 3541
Registriert: Sonntag 5. Februar 2006, 22:35
Wohnort: Westerwald
Kontaktdaten:

Beitragvon Dianu » Dienstag 3. Mai 2005, 22:19

Hallo Ed,
wahrscheinlich koennte jeder von uns ein dickes Buch ueber "die Entwicklung der Elektronik in den letzten paar Jahrzenten" schreiben.
Bei mir hat sich durch PET und 6502-Assembler/Basic der Z80 und damit CP/M und dann natuerlich auch MSDOS als 'Klassenfeind' dargestellt.
Die gewisse Annaeherung kam dann durch '8048' mit selbst geschriebenem Assembler und danach 8051 mit Intels PL/M-Compiler.
Windows ist ein zweischneidiges Schwert: ich kann verstehen, warum es diesen enormen Erfolg hat und ich kann auch nachvollziehen, warum man es so verachten kann.
Beruflich bin ich schon lange selbstaendig und entwickle Steuerungen fuer Kunden und fertige mit Wellenloetbad und ein paar Betueckerinnen auch die folgenden Serien dazu.
meine Homepage
Liebe Gruesse

Dianu

edgar
Stamm-Mitglied
Beiträge: 5941
Registriert: Samstag 19. Februar 2005, 11:33

Beitragvon edgar » Mittwoch 4. Mai 2005, 14:47

Tag Rudo,

habe gestern abend Deine WebSeiten angeschaut....und ein e-mail an die dortige Adresse abgeschickt....wurde aber bei Dir nicht angenommen?...oder doch ? Ansonsten schicke ich nochmals.
Habe hier die Adresse des Webmasters gesucht und nicht gefunden....oder war es zu spaet?

Ciao
Edgar

Benutzeravatar
Dianu
Site Admin
Beiträge: 3541
Registriert: Sonntag 5. Februar 2006, 22:35
Wohnort: Westerwald
Kontaktdaten:

Beitragvon Dianu » Mittwoch 4. Mai 2005, 16:21

Hallo Edgar,
ein e-mail von dir hab ich nicht gesehen.
Es gibt da aber viele Fallen:
1. deine e-mail Adresse fuer dieses Forum funktioniert nicht, deshalb habe ich die automatische Bestaetigung an Dich beim Registrieren fuer dieses Forum zurueckbekommen. Daraufhin habe ich e. PN geschrieben (vom 19.2.), die hast du aber noch nicht abgeholt. Wahrscheinlich funktioniert die Forumssoftware auch nicht richt richtig, denn es steht in deinem Fall dort oben, dass du keine neue Nachrichten hast. Du hast aber doch eine, klicke einfach mal auf "Du hast keine neue Nachrichten".

Schicke mir mal eine PN, mal sehen ob das funktioniert.

2. Auf der HP kannste die angegebene e-mail benutzen, ich bin auch der webmaster der Domain, aber dort kommt auch viel Schrott an.

3. Die e-mail Adressen xyz@t-online.de werden alle ca. Ende Mai von der Telecom abgekuendigt. Man will diese alten Vertraege nicht mehr unterstuetzen, dieser e-mail-Server der Telekom wird ersatzlos abgeschaltet - also nicht mehr benutzen. (Im Moment geht der noch, kann also nichts mit deinem Problem zu tun haben)

4. Wenn du die Domain dianu.de meinst, dann frage ich immer nur
hobby@dianu.de
ab.
Dieser e-mail server koennte auch Probleme machen, weil es kein normaler POP3-Server sondern ein IMAP-Server ist. Der Provider will das nur so.

ciao
Liebe Gruesse

Dianu


Zurück zu „PC-Software“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast